summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:30:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:30:18 +0000
commit88163e91e8a5b27947f8c2f12f426b29a3d639aa (patch)
tree3e12c4ee9ca774a8a47cf16fc6022ce747f56578 /include/subdir.mk
parenta4431001972b462b99d19f583c24b37f851dfbbf (diff)
downloadmaster-31e0f0ae-88163e91e8a5b27947f8c2f12f426b29a3d639aa.tar.gz
master-31e0f0ae-88163e91e8a5b27947f8c2f12f426b29a3d639aa.tar.bz2
master-31e0f0ae-88163e91e8a5b27947f8c2f12f426b29a3d639aa.zip
ignore dependencies when using QUILT
SVN-Revision: 8244
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 4348c7b93d..e985c30ff0 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -23,7 +23,7 @@ define subdir
$(foreach bd,$($(1)/builddirs),
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
- $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
+ $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+$$(MAKE) -j1 -C $(1)/$(bd) $(target)
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))