summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-07-11 12:48:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-07-11 12:48:59 +0000
commit7dc435ea2965a0219c3a4e8b2a717030a30b4cad (patch)
tree09270b7a6c1e71d16d0b0fac142cb26ae6068073 /include/subdir.mk
parentc2216626e199a1da5adb851c0ec25038a579424f (diff)
downloadmaster-31e0f0ae-7dc435ea2965a0219c3a4e8b2a717030a30b4cad.tar.gz
master-31e0f0ae-7dc435ea2965a0219c3a4e8b2a717030a30b4cad.tar.bz2
master-31e0f0ae-7dc435ea2965a0219c3a4e8b2a717030a30b4cad.zip
move the toolchain_install stampfile to the right place to fix spurious missing toolchain errors after cleaning stuff
SVN-Revision: 16776
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d93d40fca7..3c1e3f9cae 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -47,9 +47,9 @@ define subdir
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
-# Parameters: <subdir> <name> <target> <depends> <config options>
+# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+ $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)