summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
commit761dc0a0aea048ef228635a271ef6d3daf0d0518 (patch)
tree03331e3489694b00957056e8263d9363bcde76ba /include/subdir.mk
parent82914583a98af72e6e117e3ca2feffdf532e3eb5 (diff)
downloadmaster-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.tar.gz
master-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.tar.bz2
master-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.zip
fix a dependency bug
SVN-Revision: 8561
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 0a3eff307e..40a06ed9e1 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -38,7 +38,7 @@ endef
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build
- @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))