summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-05-07 16:45:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-05-07 16:45:00 +0000
commit31a3a503ccf0ff54a3250aeec911f9188204e814 (patch)
tree03dbb3127cff17b1a6c6bfc19fdf982ce0992fa8 /include/subdir.mk
parent4a2ab2e0d424225461f78798fd12ddd37a49334e (diff)
downloadmaster-31e0f0ae-31a3a503ccf0ff54a3250aeec911f9188204e814.tar.gz
master-31e0f0ae-31a3a503ccf0ff54a3250aeec911f9188204e814.tar.bz2
master-31e0f0ae-31a3a503ccf0ff54a3250aeec911f9188204e814.zip
add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
SVN-Revision: 11059
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d62df7efa7..3097ea418d 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -28,7 +28,8 @@ define subdir
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
- +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+ +$$(MAKE) -j1 -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
+
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
# legacy targets