summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-18 21:53:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-18 21:53:35 +0000
commit227399122b7cf9c95acd0d375c5aef6df2e73b57 (patch)
tree35e49ddb82c1ca3c56faac58bce0957a9b423583 /include/subdir.mk
parent726eb970d65c6025f8bc438600d03cdb4c36ffa0 (diff)
downloadmaster-31e0f0ae-227399122b7cf9c95acd0d375c5aef6df2e73b57.tar.gz
master-31e0f0ae-227399122b7cf9c95acd0d375c5aef6df2e73b57.tar.bz2
master-31e0f0ae-227399122b7cf9c95acd0d375c5aef6df2e73b57.zip
add makefile target alias package/<name>/host/<target> for host builds
SVN-Revision: 14944
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index e6c8066187..40e31923bc 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -31,6 +31,7 @@ define subdir
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(btype)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(btype)/$(target)) $(call $(1)//$(btype)/$(target),$(1)/$(bd)/$(btype))))
+$$(SUBMAKE) -C $(1)/$(bd) $(btype)-$(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(btype)-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) [$(btype)] failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(btype)/$(target))
+ $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
)
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))