summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:16 +0000
commit167846e488603313b5b61d350219e872a24ac471 (patch)
treebe13e37166f43d9d56d908526fb7d45aecea079b /include/subdir.mk
parent976b78a306c70280e87e49d0aa3dc0c9782ac264 (diff)
downloadmaster-31e0f0ae-167846e488603313b5b61d350219e872a24ac471.tar.gz
master-31e0f0ae-167846e488603313b5b61d350219e872a24ac471.tar.bz2
master-31e0f0ae-167846e488603313b5b61d350219e872a24ac471.zip
add support for config options checking in top-level directory stampfiles
SVN-Revision: 15112
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 40e31923bc..d4076e6c47 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -46,9 +46,9 @@ define subdir
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
-# Parameters: <subdir> <name> <target> <depends>
+# Parameters: <subdir> <name> <target> <depends> <config options>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+ $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)