summaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
commit00d1e599d753602c18f34d9642574d70b97e607d (patch)
tree8e81bd68be8fbbb35642d243211ede63a864ee10 /include/subdir.mk
parentea70b60a072edab2da2ae77e91c21f233c548eff (diff)
downloadmaster-31e0f0ae-00d1e599d753602c18f34d9642574d70b97e607d.tar.gz
master-31e0f0ae-00d1e599d753602c18f34d9642574d70b97e607d.tar.bz2
master-31e0f0ae-00d1e599d753602c18f34d9642574d70b97e607d.zip
add a command for printing a cleaned up make target database - will be used to analyze package dependencies at some point
SVN-Revision: 22871
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk13
1 files changed, 8 insertions, 5 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index b8094afb2e..afc95a4427 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -39,16 +39,18 @@ define subdir
+$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) BUILD_VARIANT="$(filter-out __default,$(variant))" $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build$(if $(filter-out __default,$(variant)), (build variant: $(variant))).))
)
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
-
- # legacy targets
- $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
- # aliases
- $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(target): $(1)/$(bd)/$(target)))
+ $(if $(DUMP_TARGET_DB),,
+ # legacy targets
+ $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
+ # aliases
+ $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(target): $(1)/$(bd)/$(target)))
+ )
)
)
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
+ifndef DUMP_TARGET_DB
# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
$(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
@@ -67,3 +69,4 @@ define stampfile
@rm -f $$($(1)/stamp-$(3))
endef
+endif