summaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:56 +0000
commitb0d8473bf4dc49c5e49f9151a803402af1223a32 (patch)
tree5154bb2020dae1b2e505dc9888dc15ea703fc995 /include/scan.mk
parent6f16d961a588782f22f54775194a1e66a1ffeb53 (diff)
downloadmaster-31e0f0ae-b0d8473bf4dc49c5e49f9151a803402af1223a32.tar.gz
master-31e0f0ae-b0d8473bf4dc49c5e49f9151a803402af1223a32.tar.bz2
master-31e0f0ae-b0d8473bf4dc49c5e49f9151a803402af1223a32.zip
get rid of a shell warning if md5sum is not found
SVN-Revision: 12494
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 19350b612b..7b818e8aba 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -52,7 +52,7 @@ $(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
$(TARGET_STAMP)::
+( \
$(NO_TRACE_MAKE) $(FILELIST); \
- MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) | awk '{print $$1}'); \
+ MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) 2>/dev/null | awk '{print $$1}'); \
[ -f "$@.$$MD5SUM" ] || { \
rm -f $@.*; \
touch $@.$$MD5SUM; \