summaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:22 +0000
commit988e3d85b06d581c057141c08e732883ec11cf17 (patch)
tree750ddd8aa6ac1d1870c9fa54583b9b7a78ae1a32 /include/scan.mk
parent061d516d43fb8227bc0deafe706d14cc991c802c (diff)
downloadmaster-31e0f0ae-988e3d85b06d581c057141c08e732883ec11cf17.tar.gz
master-31e0f0ae-988e3d85b06d581c057141c08e732883ec11cf17.tar.bz2
master-31e0f0ae-988e3d85b06d581c057141c08e732883ec11cf17.zip
include/scan.mk: Add -a argument to the grep to treat all Makefiles as a text file.
Hello, I found out that in some rare cases grep can treat Makefile as a binary file. That happened to me on UTF-8 Gentoo if Makefile contained a character which was from extended ASCII table. Without this patch the output of the grep command in the $(FILELIST) target is not valid (contains line "Binary file matches") and following commands fail to create feed index file. Best Regards, Martin Strbacka Signed-off-by: Martin Strbacka <martin.strbacka@nic.cz> SVN-Revision: 45966
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index c2a8f7eabb..5af035972f 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -55,7 +55,7 @@ endif
$(FILELIST): $(OVERRIDELIST)
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
+ $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -aHE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \