summaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-15 11:07:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-15 11:07:29 +0000
commit50a5a8df2259ebdcc03dae3491e119fc2225e1ed (patch)
tree431f8035f2229e3692e1c543beac5e1d2f879583 /include/scan.mk
parent1592f3f607e242de18c38b76b95399119439157f (diff)
downloadmaster-31e0f0ae-50a5a8df2259ebdcc03dae3491e119fc2225e1ed.tar.gz
master-31e0f0ae-50a5a8df2259ebdcc03dae3491e119fc2225e1ed.tar.bz2
master-31e0f0ae-50a5a8df2259ebdcc03dae3491e119fc2225e1ed.zip
build: use different grep strings for scanning package vs target metadata
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44774
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index c3015793d2..c2a8f7eabb 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -47,9 +47,15 @@ $(OVERRIDELIST):
rm -f $(TMP_DIR)/info/.overrides-$(SCAN_TARGET)-*
touch $@
+ifeq ($(SCAN_NAME),target)
+ GREP_STRING=BuildTarget
+else
+ GREP_STRING=(Build/DefaultTargets|BuildPackage|.+Package)
+endif
+
$(FILELIST): $(OVERRIDELIST)
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Target)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
+ $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \