summaryrefslogtreecommitdiffstats
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-24 03:29:31 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-24 03:37:08 +0200
commitc15d70c6d6a00529a119a41b97953eac9c41a8fc (patch)
tree5270851a7efecdf7fa01f348f0188acc72096f6f /include/rootfs.mk
parentd72e838429cbe7638b383b99bf16d97a63f80837 (diff)
downloadmaster-31e0f0ae-c15d70c6d6a00529a119a41b97953eac9c41a8fc.tar.gz
master-31e0f0ae-c15d70c6d6a00529a119a41b97953eac9c41a8fc.tar.bz2
master-31e0f0ae-c15d70c6d6a00529a119a41b97953eac9c41a8fc.zip
image: don't override opkg list directory in per-device rootfs mode
opkg's -l option is always interpreted relative to the installation root. This leads to very weird paths inside the rootfs (containing the whole path to the LEDE tree on the build machine) and causes the subsequent deletion of the list directory to fail (cluttering the resulting images). Instead, use the default list directory and remove its contents in prepare_rootfs. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index f3ba33a2be..6ca7c9c322 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -72,6 +72,7 @@ define prepare_rootfs
@-find $(1) -name .svn | $(XARGS) rm -rf
@-find $(1) -name .git | $(XARGS) rm -rf
@-find $(1) -name '.#*' | $(XARGS) rm -f
+ rm -f $(1)/usr/lib/opkg/lists/*
rm -f $(1)/usr/lib/opkg/info/*.postinst*
rm -f $(1)/usr/lib/opkg/info/*.prerm*
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(1)/usr/lib/opkg)