summaryrefslogtreecommitdiffstats
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 15:25:38 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 17:57:58 +0200
commit021b96d7c5c668fbcb5375c65cee90832bb2854f (patch)
tree216f408ebe7f02da577aaaeacde8641e833f2d03 /include/rootfs.mk
parent593dfac90938d62558de1fa13ac027c319284fe3 (diff)
downloadmaster-31e0f0ae-021b96d7c5c668fbcb5375c65cee90832bb2854f.tar.gz
master-31e0f0ae-021b96d7c5c668fbcb5375c65cee90832bb2854f.tar.bz2
master-31e0f0ae-021b96d7c5c668fbcb5375c65cee90832bb2854f.zip
rootfs: remove unnecessary and potentially harmful force flags from opkg call
Especially --force-overwrite and --force-depends will often lead to broken images; it's better to fail the build in such cases than to silently ignore the errors. Instead, ignore errors in the per-device rootfs opkg remove command, so the build doesn't break when packages can't be removed because of dependencies. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 6a6610019f..15f71ae0df 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -40,10 +40,7 @@ opkg = \
TMPDIR=$(1)/tmp \
$(STAGING_DIR_HOST)/bin/opkg \
--offline-root $(1) \
- --force-depends \
- --force-overwrite \
--force-postinstall \
- --force-maintainer \
--add-dest root:/ \
--add-arch all:100 \
--add-arch $(if $(ARCH_PACKAGES),$(ARCH_PACKAGES),$(BOARD)):200