summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
commitddcfaeb1e516d569436c3d4d453a9573655ca375 (patch)
tree94b1169c72a68b9ef6ce9ab92aea68eb8764358a /include/quilt.mk
parent7ef6b7451973d0d3fd09014871e7859b6a83fb19 (diff)
downloadmaster-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.gz
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.bz2
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.zip
move host build in packages into a separate namespace: package/<name>/host/<target> this allows dependencies between host and target packages, and saves unnecessary host builds for packages that contain both variants
SVN-Revision: 14905
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 0d63e62fd2..fbb3e01e35 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -67,7 +67,7 @@ ifneq ($(PKG_BUILD_DIR),)
endif
ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(if $(wildcard $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used),y)
+ HOST_QUILT?=$(if $(findstring command,$(origin $(QUILT))),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
ifneq ($(HOST_QUILT),)
HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked