summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 17:50:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 17:50:31 +0000
commitbc6fcb0067e2af16337cd3144c4c5ab532f09ac0 (patch)
tree8448fe9c85f22a4cb81881229faf799010bf5a5d /include/quilt.mk
parent745ccfb97e13183f7bd2a869e7dca42138a375c3 (diff)
downloadmaster-31e0f0ae-bc6fcb0067e2af16337cd3144c4c5ab532f09ac0.tar.gz
master-31e0f0ae-bc6fcb0067e2af16337cd3144c4c5ab532f09ac0.tar.bz2
master-31e0f0ae-bc6fcb0067e2af16337cd3144c4c5ab532f09ac0.zip
eliminate redundancy by creating the quilt_used stampfile in the right place
SVN-Revision: 14620
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 4323c77b2b..77b76a6dae 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -79,11 +79,13 @@ endif
define Host/Patch/Default
$(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
$(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+ $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef
define Build/Patch/Default
$(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
$(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+ $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)