summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 19:52:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 19:52:54 +0000
commit9cc960cad96fcef65fd8cf9a0ed8f41c65cfad97 (patch)
treee1e2310310cc4d9f78908abc5c219f881223c447 /include/quilt.mk
parent6992efe2bb88291d9f3d20ed85b7b88d8f6ae23e (diff)
downloadmaster-31e0f0ae-9cc960cad96fcef65fd8cf9a0ed8f41c65cfad97.tar.gz
master-31e0f0ae-9cc960cad96fcef65fd8cf9a0ed8f41c65cfad97.tar.bz2
master-31e0f0ae-9cc960cad96fcef65fd8cf9a0ed8f41c65cfad97.zip
more fixes for the patching stuff (was testing it on the wrong target)
SVN-Revision: 7483
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index e77e0db772..e8c3b90a68 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -49,8 +49,9 @@ define Kernel/Patch/Default
if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
)
$(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
- if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+ if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
)
+ $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
$(STAMP_PATCHED): $(STAMP_PREPARED)