summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-28 07:14:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-28 07:14:22 +0000
commit68d6dcf7c4ad6edb80679b33b28761cb5ed959ec (patch)
tree4a98abeea1af54b323ad0f48bc5809a72c603707 /include/quilt.mk
parent7e79cae09004230dd7e7ac7978746c2085b1667d (diff)
downloadmaster-31e0f0ae-68d6dcf7c4ad6edb80679b33b28761cb5ed959ec.tar.gz
master-31e0f0ae-68d6dcf7c4ad6edb80679b33b28761cb5ed959ec.tar.bz2
master-31e0f0ae-68d6dcf7c4ad6edb80679b33b28761cb5ed959ec.zip
allow packages to override the patch directory using the PATCH_DIR variable
SVN-Revision: 7750
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 47195293e8..c1f7bacd3b 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -8,6 +8,7 @@
ifeq ($(KERNEL_BUILD),1)
PKG_BUILD_DIR:=$(LINUX_DIR)
endif
+PATCH_DIR?=./patches
define Quilt/Patch
@for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
@@ -28,7 +29,7 @@ ifneq ($(QUILT),)
define Build/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches
mkdir -p $(PKG_BUILD_DIR)/patches
- $(call Quilt/Patch,./patches,)
+ $(call Quilt/Patch,$(PATCH_DIR),)
@echo
touch $(PKG_BUILD_DIR)/.quilt_used
endef
@@ -37,8 +38,8 @@ ifneq ($(QUILT),)
quilt-check: $(STAMP_PATCHED)
else
define Build/Patch/Default
- @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
- $(PATCH) $(PKG_BUILD_DIR) ./patches; \
+ @if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
fi
endef
endif
@@ -75,7 +76,7 @@ define Quilt/RefreshDir
endef
define Quilt/Refresh/Package
- $(call Quilt/RefreshDir,./patches)
+ $(call Quilt/RefreshDir,$(PATCH_DIR))
endef
define Quilt/Refresh/Kernel