summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 07:33:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 07:33:00 +0000
commit5e406f0a282871d0e1043bebeb4320de64d1fda0 (patch)
tree08ebb39a2f3a21ff9553bbe837e4ecafa9bca3da /include/quilt.mk
parent396895e6d88bb0c9adae73f6f75b47f90cd29c9b (diff)
downloadmaster-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.tar.gz
master-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.tar.bz2
master-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.zip
enable quilt for host builds and add some additional checks
SVN-Revision: 7473
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 5fbdda1b9f..beb0840c00 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -10,7 +10,7 @@ ifneq ($(QUILT),)
STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
CONFIG_AUTOREBUILD=
- PATCHES:=$(shell cd ./patches; ls)
+ PATCHES:=$(shell (cd ./patches && ls) 2>/dev/null)
define Build/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches
mkdir -p $(PKG_BUILD_DIR)/patches
@@ -36,18 +36,23 @@ endif
$(STAMP_PATCHED): $(STAMP_PREPARED)
@cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
- cd $(PKG_BUILD_DIR); quilt push -a
+ $(if $(strip $(PATCHES)),cd $(PKG_BUILD_DIR); quilt push -a)
touch $@
refresh: $(STAMP_PREPARED)
+ @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
+ echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
+ false; \
+ }
@[ -f "$(PKG_BUILD_DIR)/patches/series" ] || { \
- echo "The source directory was not unpacked using quilt. Please rebuild."; \
+ echo "The source directory contains no quilt patches."; \
false; \
}
@[ "$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
echo "The patches are not sorted in the right order. Please fix."; \
false; \
}
+ mkdir -p ./patches
rm -f ./patches/* 2>/dev/null >/dev/null
@( \
for patch in $$(cat $(PKG_BUILD_DIR)/patches/series); do \