summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-18 07:28:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-18 07:28:31 +0000
commit5175e0e45c4f1c6b537dad400c06247594f5a719 (patch)
tree30e465a4d49e301fd8f0fad2128c1df1053c186e /include/quilt.mk
parentfd5595ed5cfa9a218dbdefc528072d4a549e7059 (diff)
downloadmaster-31e0f0ae-5175e0e45c4f1c6b537dad400c06247594f5a719.tar.gz
master-31e0f0ae-5175e0e45c4f1c6b537dad400c06247594f5a719.tar.bz2
master-31e0f0ae-5175e0e45c4f1c6b537dad400c06247594f5a719.zip
fail in .quilt_patched when there were patches that didn't apply
SVN-Revision: 8024
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index fb5528e884..7714f29119 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -61,7 +61,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
cd $(PKG_BUILD_DIR)/patches; \
find * -type f \! -name series | sort > series; \
)
- -[ -s "$(PKG_BUILD_DIR)/patches/series" ] && (cd $(PKG_BUILD_DIR); quilt push -a)
+ if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
touch $@
define Quilt/RefreshDir