summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
commit431c9267b4016b7e712a0edf1e594bd71ac850b4 (patch)
tree2ac6aae6590e7bd3fec6de9d2446b64acf4aa4ed /include/quilt.mk
parentf3c14b3de8490a16cdb59f18239ce5afd3372708 (diff)
downloadmaster-31e0f0ae-431c9267b4016b7e712a0edf1e594bd71ac850b4.tar.gz
master-31e0f0ae-431c9267b4016b7e712a0edf1e594bd71ac850b4.tar.bz2
master-31e0f0ae-431c9267b4016b7e712a0edf1e594bd71ac850b4.zip
replace a few unnecessary $(shell) calls
SVN-Revision: 14739
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index c5245a8aee..0d63e62fd2 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -56,7 +56,7 @@ $(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)
endef
ifneq ($(PKG_BUILD_DIR),)
- QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
+ QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
ifneq ($(QUILT),)
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
@@ -67,7 +67,7 @@ ifneq ($(PKG_BUILD_DIR),)
endif
ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(strip $(shell test -f $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used && echo y))
+ HOST_QUILT?=$(if $(wildcard $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used),y)
ifneq ($(HOST_QUILT),)
HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked