summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-21 19:26:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-21 19:26:36 +0000
commit40b5e7a30d3d767f5a220be3e716d6a8fe7aaa53 (patch)
tree3822bec6ef204d200945eca3c4da5a2526e52b20 /include/quilt.mk
parent6585073a0400b93fa5c8d6a0982ae09a8e7f6d4c (diff)
downloadmaster-31e0f0ae-40b5e7a30d3d767f5a220be3e716d6a8fe7aaa53.tar.gz
master-31e0f0ae-40b5e7a30d3d767f5a220be3e716d6a8fe7aaa53.tar.bz2
master-31e0f0ae-40b5e7a30d3d767f5a220be3e716d6a8fe7aaa53.zip
fix prepare error with brcm-2.4 and missing files/ (thx, thepeople)
SVN-Revision: 13021
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index c569231173..d3233d8238 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -66,9 +66,10 @@ define Build/Patch/Default
$(call PatchDir,$(PATCH_DIR),)
endef
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
- $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+ $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)