summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 06:54:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 06:54:46 +0000
commit396895e6d88bb0c9adae73f6f75b47f90cd29c9b (patch)
tree9d6eaad5b8deaa356e56b3ec0125bff6e49d5a9a /include/quilt.mk
parentcc690d782c81197478adcdb5fb99061969adf756 (diff)
downloadmaster-31e0f0ae-396895e6d88bb0c9adae73f6f75b47f90cd29c9b.tar.gz
master-31e0f0ae-396895e6d88bb0c9adae73f6f75b47f90cd29c9b.tar.bz2
master-31e0f0ae-396895e6d88bb0c9adae73f6f75b47f90cd29c9b.zip
Improve quilt patch handling: All quilt managed patches are checked before the package compile is attempted
SVN-Revision: 7472
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk18
1 files changed, 13 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index ec5acc507e..5fbdda1b9f 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -5,24 +5,27 @@
# See /LICENSE for more information.
#
-QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_patched && echo y))
+QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
ifneq ($(QUILT),)
STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
+ STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
CONFIG_AUTOREBUILD=
PATCHES:=$(shell cd ./patches; ls)
define Build/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches
mkdir -p $(PKG_BUILD_DIR)/patches
- for patch in $(PATCHES); do ( \
+ @for patch in $(PATCHES); do ( \
cp "./patches/$$$$patch" $(PKG_BUILD_DIR); \
cd $(PKG_BUILD_DIR); \
quilt import -p 1 "$$$$patch"; \
- quilt push; \
- quilt refresh; \
+ quilt push -f >/dev/null 2>/dev/null; \
rm -f "$$$$patch"; \
); done
- touch $(PKG_BUILD_DIR)/.quilt_patched
+ @echo
+ touch $(PKG_BUILD_DIR)/.quilt_used
endef
+ $(STAMP_CONFIGURED): $(STAMP_PATCHED)
+ prepare: $(STAMP_PATCHED)
else
define Build/Patch/Default
@if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
@@ -31,6 +34,11 @@ else
endef
endif
+$(STAMP_PATCHED): $(STAMP_PREPARED)
+ @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+ cd $(PKG_BUILD_DIR); quilt push -a
+ touch $@
+
refresh: $(STAMP_PREPARED)
@[ -f "$(PKG_BUILD_DIR)/patches/series" ] || { \
echo "The source directory was not unpacked using quilt. Please rebuild."; \