summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 22:51:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 22:51:02 +0000
commit2cb6cbf0618b0b8e08b34dff4fcb02e6cc2183ac (patch)
tree16e3601b3c84efdfbe9e13f53088441844531ded /include/quilt.mk
parent98f43a2494cc16eec417f55e99102701ed9c9be9 (diff)
downloadmaster-31e0f0ae-2cb6cbf0618b0b8e08b34dff4fcb02e6cc2183ac.tar.gz
master-31e0f0ae-2cb6cbf0618b0b8e08b34dff4fcb02e6cc2183ac.tar.bz2
master-31e0f0ae-2cb6cbf0618b0b8e08b34dff4fcb02e6cc2183ac.zip
fix quilt apply for packages that change STAMP_*
SVN-Revision: 9531
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 04ebfc3490..f07f4c5249 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -56,7 +56,6 @@ ifneq ($(QUILT),)
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
override CONFIG_AUTOREBUILD=
- $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
prepare: $(STAMP_PATCHED)
quilt-check: $(STAMP_CHECKED)
endif
@@ -101,32 +100,33 @@ define Quilt/Refresh
$(if $(TARGET_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
endef
-$(STAMP_PATCHED): $(STAMP_PREPARED)
+define Build/Quilt
+ $(STAMP_PATCHED): $(STAMP_PREPARED)
@( \
cd $(PKG_BUILD_DIR)/patches; \
quilt pop -a -f >/dev/null 2>/dev/null; \
if [ -s ".subdirs" ]; then \
rm -f series; \
- for file in $$(cat .subdirs); do \
- if [ -f $$file/series ]; then \
+ for file in $$$$(cat .subdirs); do \
+ if [ -f $$$$file/series ]; then \
echo "Converting $$file/series"; \
- $(call filter_series,$$file/series) | awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' | sed -e s,//,/,g >> series; \
+ $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
else \
- echo "Sorting patches in $$file"; \
- find $$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
+ echo "Sorting patches in $$$$file"; \
+ find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
fi; \
done; \
else \
find * -type f \! -name series | sort > series; \
fi; \
)
- touch $@
+ touch $$@
-$(STAMP_CHECKED): $(STAMP_PATCHED)
+ $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
+ $(STAMP_CHECKED): $(STAMP_PATCHED)
if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
- touch $@
+ touch $$@
-define Build/Quilt
quilt-check: $(STAMP_PREPARED) FORCE
@[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \