summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-05 14:08:47 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-05 14:17:08 +0200
commit22ef1c83b35cd5633b0c58c9c38a43494a906a6a (patch)
treee790cae0c3ca6ed67e48d184999c3e46ae96d483 /include/quilt.mk
parent51e70267bd7ba886314f87317f31342f8e39f602 (diff)
downloadmaster-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.tar.gz
master-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.tar.bz2
master-31e0f0ae-22ef1c83b35cd5633b0c58c9c38a43494a906a6a.zip
kernel: make the kernel build auto-clean the build dir like package builds
Previous behavior can be restored by using QUILT=1 on target/prepare Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index b18b6364fe..cd392a7c5d 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -91,7 +91,7 @@ endef
kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
define Kernel/Patch/Default
- rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
+ $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
$(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)