summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commit1e570a9288856bcd288a80115f2233c9c785706c (patch)
tree8491af08bde47e22f96c01e6f560206b3fd02a4a /include/quilt.mk
parent487c622ac0c37f3cd26add56df9081ea7caf3835 (diff)
downloadmaster-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.tar.gz
master-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.tar.bz2
master-31e0f0ae-1e570a9288856bcd288a80115f2233c9c785706c.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
SVN-Revision: 13010
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 70bc84e4cc..c569231173 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -68,11 +68,8 @@ endef
define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
- if [ -d $(GENERIC_FILES_DIR) ]; then $(CP) $(GENERIC_FILES_DIR)/* $(LINUX_DIR)/; fi
- if [ -d $(FILES_DIR) ]; then \
- $(CP) $(FILES_DIR)/* $(LINUX_DIR)/; \
- find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
- fi
+ $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+ find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)
endef