summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-04-12 21:11:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-04-12 21:11:24 +0000
commit149341faf161c9144355e1cd75550bd6fe8e37d0 (patch)
tree791e532aa91f7c770572b2e853be1cf1c13c5b29 /include/quilt.mk
parent92bd56fea14c75c16e3f438c64996a39da0de6cb (diff)
downloadmaster-31e0f0ae-149341faf161c9144355e1cd75550bd6fe8e37d0.tar.gz
master-31e0f0ae-149341faf161c9144355e1cd75550bd6fe8e37d0.tar.bz2
master-31e0f0ae-149341faf161c9144355e1cd75550bd6fe8e37d0.zip
silence error when package has no patches (patchwork 321)
SVN-Revision: 26627
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 9691dc3276..a9af2268bc 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -39,7 +39,7 @@ define PatchDir/Quilt
endef
define PatchDir/Default
- @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+ @if [ -d "$(2)" ] && [ "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
export PATCH="$(PATCH)"; \
if [ -s "$(2)/series" ]; then \
$(call filter_series,$(2)/series) | xargs -n1 \