summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-29 00:25:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-29 00:25:38 +0000
commit03543ec4a4ee24df583843d386a7a39372865961 (patch)
tree12e82be82d45569ed99f6d9db47a2141c4b85e65 /include/quilt.mk
parent894bd2f7dc0ab47b2ba975e7ed270531136f4847 (diff)
downloadmaster-31e0f0ae-03543ec4a4ee24df583843d386a7a39372865961.tar.gz
master-31e0f0ae-03543ec4a4ee24df583843d386a7a39372865961.tar.bz2
master-31e0f0ae-03543ec4a4ee24df583843d386a7a39372865961.zip
proper series file support for regular packages
SVN-Revision: 9059
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 4dce2a6d8c..c156d3062d 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -44,7 +44,12 @@ ifneq ($(QUILT),)
else
define Build/Patch/Default
@if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
- $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ if [ -f $(PATCH_DIR)/series ]; then \
+ grep -vE '^#' $(PATCH_DIR)/series | xargs -n1 \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ else \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ fi; \
fi
endef
endif