summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-04-03 18:37:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-04-03 18:37:30 +0000
commit03354353afb128342cdd3d76b89eee38b37978d6 (patch)
tree2cceb9babf44dd4d2d0fbe1bd65415915515d00c /include/quilt.mk
parentdd2afbeee3b7cb99b65585e5bacdcd403c51996e (diff)
downloadmaster-31e0f0ae-03354353afb128342cdd3d76b89eee38b37978d6.tar.gz
master-31e0f0ae-03354353afb128342cdd3d76b89eee38b37978d6.tar.bz2
master-31e0f0ae-03354353afb128342cdd3d76b89eee38b37978d6.zip
clean up reject files after copying target/linux/*/files to the kernel tree
SVN-Revision: 10722
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index f07f4c5249..95f81e7094 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -68,7 +68,10 @@ endef
define Kernel/Patch/Default
$(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
- if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+ if [ -d ./files ]; then \
+ $(CP) ./files/* $(LINUX_DIR)/; \
+ find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
+ fi
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)
endef