summaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 08:28:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 08:28:05 +0000
commit3b6b7a2d1ba44030e9b2909914d145b79ad7a1e2 (patch)
treeee5867150087006834a1a4539f5928c1e6b63810 /include/quilt.mk
parent5e406f0a282871d0e1043bebeb4320de64d1fda0 (diff)
downloadmaster-31e0f0ae-3b6b7a2d1ba44030e9b2909914d145b79ad7a1e2.tar.gz
master-31e0f0ae-3b6b7a2d1ba44030e9b2909914d145b79ad7a1e2.tar.bz2
master-31e0f0ae-3b6b7a2d1ba44030e9b2909914d145b79ad7a1e2.zip
implement quilt handling for the kernel tree ... and there was much rejoicing!
SVN-Revision: 7474
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk70
1 files changed, 54 insertions, 16 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index beb0840c00..dbf0435f99 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -5,22 +5,30 @@
# See /LICENSE for more information.
#
+ifeq ($(KERNEL_BUILD),1)
+ PKG_BUILD_DIR:=$(LINUX_DIR)
+endif
+
+define Quilt/Patch
+ @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
+ cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
+ cd $(PKG_BUILD_DIR); \
+ quilt import -P$(2)$$$$patch -p 1 "$$$$patch"; \
+ quilt push -f >/dev/null 2>/dev/null; \
+ rm -f "$$$$patch"; \
+ ); done
+endef
+
QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
ifneq ($(QUILT),)
STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
CONFIG_AUTOREBUILD=
- PATCHES:=$(shell (cd ./patches && ls) 2>/dev/null)
+ PATCHES:=$(shell )
define Build/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches
mkdir -p $(PKG_BUILD_DIR)/patches
- @for patch in $(PATCHES); do ( \
- cp "./patches/$$$$patch" $(PKG_BUILD_DIR); \
- cd $(PKG_BUILD_DIR); \
- quilt import -p 1 "$$$$patch"; \
- quilt push -f >/dev/null 2>/dev/null; \
- rm -f "$$$$patch"; \
- ); done
+ $(call Quilt/Patch,./patches,)
@echo
touch $(PKG_BUILD_DIR)/.quilt_used
endef
@@ -34,11 +42,46 @@ else
endef
endif
+define Kernel/Patch/Default
+ if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
+ if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+ $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PLATFORM_DIR)/patches,generic/), \
+ if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
+ )
+ $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
+ if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+ )
+ touch $(PKG_BUILD_DIR)/.quilt_used
+endef
+
$(STAMP_PATCHED): $(STAMP_PREPARED)
@cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
- $(if $(strip $(PATCHES)),cd $(PKG_BUILD_DIR); quilt push -a)
+ [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
touch $@
+define Quilt/RefreshDir
+ mkdir -p $(1)
+ -rm -f $(1)/* 2>/dev/null >/dev/null
+ @( \
+ for patch in $$($(if $(2),grep "^$(2)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$1}'); do \
+ $(CP) -v "$(PKG_BUILD_DIR)/patches/$$patch" $(1); \
+ done; \
+ )
+endef
+
+define Quilt/Refresh/Package
+ $(call Quilt/RefreshDir,./patches)
+endef
+
+define Quilt/Refresh/Kernel
+ @[ -z "$$(grep -v '^generic/' $(PKG_BUILD_DIR)/patches/series | grep -v '^platform/')" ] || { \
+ echo "All kernel patches must start with either generic/ or platform/"; \
+ false; \
+ }
+ $(call Quilt/RefreshDir,$(GENERIC_PLATFORM_DIR)/patches,generic/)
+ $(call Quilt/RefreshDir,./patches,platform/)
+endef
+
refresh: $(STAMP_PREPARED)
@[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
@@ -52,10 +95,5 @@ refresh: $(STAMP_PREPARED)
echo "The patches are not sorted in the right order. Please fix."; \
false; \
}
- mkdir -p ./patches
- rm -f ./patches/* 2>/dev/null >/dev/null
- @( \
- for patch in $$(cat $(PKG_BUILD_DIR)/patches/series); do \
- $(CP) -v "$(PKG_BUILD_DIR)/patches/$$patch" ./patches; \
- done; \
- )
+ $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+