summaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-16 12:38:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-16 12:38:16 +0000
commit4d01d6ccb1abc9939907f82de7e96d63ca8091ed (patch)
treefc73ec6c1a3f49b5bd2151c664b55c636ca11672 /include/prereq.mk
parente11479771d422ca9d2686c98e050d179201cc841 (diff)
downloadmaster-31e0f0ae-4d01d6ccb1abc9939907f82de7e96d63ca8091ed.tar.gz
master-31e0f0ae-4d01d6ccb1abc9939907f82de7e96d63ca8091ed.tar.bz2
master-31e0f0ae-4d01d6ccb1abc9939907f82de7e96d63ca8091ed.zip
build: do not overwrite already existing host commands
This prevents a later prereq check from overwriting the installed tar binary. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46982
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 33ac278232..6cb590e360 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -86,6 +86,7 @@ endef
# 3+: candidates
define SetupHostCommand
define Require/$(1)
+ [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
$(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
$(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \