summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2016-05-25 23:47:09 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-07 08:58:41 +0200
commitf7fb6e49f214e8a38698bab4d33551addbc04439 (patch)
treeb4467100750ac582fc27a0e2ed86a9c498257a5d /include/prereq-build.mk
parent4c5a49031eb690f1f311c9e8d4c68c541fadf5ae (diff)
downloadmaster-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.tar.gz
master-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.tar.bz2
master-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.zip
build: allow to build LEDE on latest MacOS X
Latest Xcode doesn't include openssl anymore. To compile mkimage from u-boot source you need SSL headers on your host. This patch provides libressl host package for any Darwin compilation. Unfortunately openssl from MacPorts can not be used, as the installed headers in /opt/local are breaking GDB compilation. Tested with a RB532 image build and resulting kernel booted on a device via TFTP. Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Felix Fietkau <nbd@nbd.name> [fixes, dependencies]
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 0e145c939b..42b624f817 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -71,10 +71,13 @@ $(eval $(call TestHostCommand,zlib, \
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
+# Xcode deprecated openssl, MacPorts doesn't work nicely for other packages
+ifneq ($(HOST_OS),Darwin)
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
+endif
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
@@ -160,8 +163,10 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
+ifneq ($(HOST_OS),Darwin)
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
openssl version | grep '\(OpenSSL\|LibreSSL\)'))
+endif
# Install ldconfig stub