summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-10-02 12:12:10 +0000
committerSteven Barth <cyrus@openwrt.org>2013-10-02 12:12:10 +0000
commitcbdd346b11c6f125f48cdb1e95870d16e5c0d628 (patch)
treea6c5edbe734be83f8bcd880083de81f5060132ab /include/prereq-build.mk
parent0ad1d06c13a15a9e91cc7a1a635ac678a298ed7f (diff)
downloadmaster-31e0f0ae-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.tar.gz
master-31e0f0ae-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.tar.bz2
master-31e0f0ae-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.zip
Add package signing infrastructure
Add package signing key and certificate configuration options to the "Image configuration" submenu. If enabled, the Packages.gz list will be signed as file Packages.sig. The passphrase for the signing key can be sourced from a file or entered by the user. The signing certificate is automatically added to the firmware image if opkg-smime is selected. Signed-off-by: Evan Hunt <each@isc.org> Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 38284
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 59ea7ef9a7..b7ada69bb4 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,6 +168,10 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
+$(eval $(call RequireCommand,openssl, \
+ Please install openssl. \
+))
+
define Require/gnu-find
$(FIND) --version 2>/dev/null
endef