summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
commitca8486a632823e6ed40c0d748cd08387a52615d5 (patch)
treee641e2537849520509b8a5512c5cc55a5d07a708 /include/prereq-build.mk
parent2a0825b4d3af709cbce9f5479ec0128da4bb509a (diff)
downloadmaster-31e0f0ae-ca8486a632823e6ed40c0d748cd08387a52615d5.tar.gz
master-31e0f0ae-ca8486a632823e6ed40c0d748cd08387a52615d5.tar.bz2
master-31e0f0ae-ca8486a632823e6ed40c0d748cd08387a52615d5.zip
improve support for building on mac os x by improving detection of missing components
SVN-Revision: 14180
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d6d2d73a63..f0e1da9810 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
OpenWrt can only be built on a case-sensitive filesystem \
))
+define Require/getopt
+ getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+ Please install GNU getopt \
+))
+
+define Require/fileutils
+ gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+ Please install GNU fileutils \
+))
+
define Require/working-gcc
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -