summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-30 17:14:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-30 17:14:47 +0000
commitb9831690e4f408d2a23a660c61b311d308317dcb (patch)
tree5b31fc93d4223b6d8b1d7c10eea9567ddd693162 /include/prereq-build.mk
parentbc7260a125dfca8855d22e17fd89e48bc865ed24 (diff)
downloadmaster-31e0f0ae-b9831690e4f408d2a23a660c61b311d308317dcb.tar.gz
master-31e0f0ae-b9831690e4f408d2a23a660c61b311d308317dcb.tar.bz2
master-31e0f0ae-b9831690e4f408d2a23a660c61b311d308317dcb.zip
prereq-build: check for "bc" (#13767)
bc is required by the kernel to compute timeconsts files, add bc to the list of prereq to build OpenWrt. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37108
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 59ea7ef9a7..dadce81ad5 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -183,3 +183,7 @@ endef
$(eval $(call Require,getopt-extended, \
Please install an extended getopt version that supports --long \
))
+
+$(eval $(call RequireCommand,bc, \
+ Please install bc. \
+))