summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 23:35:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 23:35:20 +0000
commita996cc1444f71e867e56c4211b859b54d67c7986 (patch)
treece01261f396cb5e1f4583b010490c60ecc8e641e /include/prereq-build.mk
parentdf261c26ba84fbdc318defc1e44435e82159c70c (diff)
downloadmaster-31e0f0ae-a996cc1444f71e867e56c4211b859b54d67c7986.tar.gz
master-31e0f0ae-a996cc1444f71e867e56c4211b859b54d67c7986.tar.bz2
master-31e0f0ae-a996cc1444f71e867e56c4211b859b54d67c7986.zip
add a build preeq check for glibc-static
SVN-Revision: 33121
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 228fcdcb0b..28c2a216b2 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -70,6 +70,15 @@ $(eval $(call Require,working-g++, \
Please install the GNU C++ Compiler (g++). \
))
+define Require/working-gcc-static
+ echo 'int main(int argc, char **argv) { return 0; }' | \
+ gcc -x c -static -o $(TMP_DIR)/a.out -
+endef
+
+$(eval $(call Require,working-gcc-static, \
+ Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+))
+
define Require/ncurses
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses