summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:14 +0000
commita7d856c4ce704ab1c45260d5e4210ad7e0288db5 (patch)
treeb87f2cce17f5428b48de5c3032f22aa17acea585 /include/prereq-build.mk
parent4f3876f4ee76645162e291356dd7adafd8865ee9 (diff)
downloadmaster-31e0f0ae-a7d856c4ce704ab1c45260d5e4210ad7e0288db5.tar.gz
master-31e0f0ae-a7d856c4ce704ab1c45260d5e4210ad7e0288db5.tar.bz2
master-31e0f0ae-a7d856c4ce704ab1c45260d5e4210ad7e0288db5.zip
add prereq check for extended getopt (#3944)
SVN-Revision: 12491
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index fbe7d69f44..d6d2d73a63 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -134,3 +134,11 @@ endef
$(eval $(call Require,gnu-find, \
Please install GNU find \
))
+
+define Require/getopt-extended
+ getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+ Please install an extended getopt version that supports --long \
+))