summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-05 14:11:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-05 14:11:25 +0000
commit9e670fcf9d436abe28df552eb7bb4cb325e354a9 (patch)
treeaef30b159c193267afb282a1a65bffc20241e20d /include/prereq-build.mk
parent38389c79c2ee89a662807e7dc4e82a5d11786ff8 (diff)
downloadmaster-31e0f0ae-9e670fcf9d436abe28df552eb7bb4cb325e354a9.tar.gz
master-31e0f0ae-9e670fcf9d436abe28df552eb7bb4cb325e354a9.tar.bz2
master-31e0f0ae-9e670fcf9d436abe28df552eb7bb4cb325e354a9.zip
build: use host cflags/ldflags for openssl prereq check
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47138
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6f491375c6..77fa991b04 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -74,7 +74,7 @@ $(eval $(call TestHostCommand,zlib, \
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
- gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+ gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \