summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-11 00:05:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-11 00:05:18 +0000
commit67edc7ec63946fca04875012fd5bc520eef01935 (patch)
tree59b4332bbdfd2fb58280aaa76ce8fa76a71bb255 /include/prereq-build.mk
parenta996cc1444f71e867e56c4211b859b54d67c7986 (diff)
downloadmaster-31e0f0ae-67edc7ec63946fca04875012fd5bc520eef01935.tar.gz
master-31e0f0ae-67edc7ec63946fca04875012fd5bc520eef01935.tar.bz2
master-31e0f0ae-67edc7ec63946fca04875012fd5bc520eef01935.zip
add remaining missing build prereq checks
SVN-Revision: 33122
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 28c2a216b2..74f1e32a6e 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -79,6 +79,16 @@ $(eval $(call Require,working-gcc-static, \
Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
))
+define Require/working-g++-static
+ echo 'int main(int argc, char **argv) { return 0; }' | \
+ g++ -x c++ -static -o $(TMP_DIR)/a.out - -lstdc++ && \
+ $(TMP_DIR)/a.out
+endef
+
+$(eval $(call Require,working-g++-static, \
+ Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
+))
+
define Require/ncurses
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
@@ -98,6 +108,15 @@ $(eval $(call Require,zlib, \
Please install zlib. (Missing libz.so or zlib.h) \
))
+define Require/zlib-static
+ echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
+ gcc -include zlib.h -x c -static -o $(TMP_DIR)/a.out - -lz
+endef
+
+$(eval $(call Require,zlib-static, \
+ Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
+))
+
$(eval $(call RequireCommand,gawk, \
Please install GNU awk. \
))