summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-20 09:23:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-20 09:23:55 +0000
commit549f7d0366170de48ce4061217f74bfab5d13472 (patch)
tree886ce613e6dc97cb1fd56e8df637c0be55e9e8cc /include/prereq-build.mk
parenta1b6a7e572f2c09162722a382b9302a86794a4d2 (diff)
downloadmaster-31e0f0ae-549f7d0366170de48ce4061217f74bfab5d13472.tar.gz
master-31e0f0ae-549f7d0366170de48ce4061217f74bfab5d13472.tar.bz2
master-31e0f0ae-549f7d0366170de48ce4061217f74bfab5d13472.zip
prereq-build: rename the openssl check to libssl, add back the old check - it is required after all
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42999
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4a87c9211a..5a743225f6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,13 +168,17 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
-define Require/openssl
+define Require/libssl
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
endef
-$(eval $(call Require,openssl, \
- Please install openssl (with development headers) \
+$(eval $(call Require,libssl, \
+ Please install the openssl library (with development headers) \
+))
+
+$(eval $(call RequireCommand,openssl, \
+ Please install openssl. \
))
define Require/gnu-find