summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
commit224760dee7a5f0913d894b7a23cc8d94b353dd70 (patch)
tree22913c0d4285a39280e60ed103f8f7872fcef437 /include/prereq-build.mk
parent029df8cc2e5f5f49d9dea1863fd9a9f37af7ccc0 (diff)
downloadmaster-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.tar.gz
master-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.tar.bz2
master-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.zip
add git checkout support
SVN-Revision: 9553
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c31020c321..9b77a1baf7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
Please install GNU tar. \
))
+define Require/git
+ which git-clone
+endef
+
+$(eval $(call Require,git, \
+ Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+ Please install the subversion client. \
+))
+
$(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))