summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:42:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:42:32 +0000
commit1f826e8992407f21ee33480a05d8c41642fb0daa (patch)
tree59a72cd8c523201493c27a912c63df9d8b2011a6 /include/prereq-build.mk
parent4224b52c3acc7203e7c2535d6806f30432dae5e3 (diff)
downloadmaster-31e0f0ae-1f826e8992407f21ee33480a05d8c41642fb0daa.tar.gz
master-31e0f0ae-1f826e8992407f21ee33480a05d8c41642fb0daa.tar.bz2
master-31e0f0ae-1f826e8992407f21ee33480a05d8c41642fb0daa.zip
Support LibreSSL as provider of openssl
The build scripts check for openssl by grepping the string "OpenSSL" in the output of openssl version command. LibreSSL fails this test as it outputs something like "LibreSSL 2.2.4". This patch fix the prereq-bulid.mk file so that it accepts LibreSSL as openssl provider as well. Signed-off-by: Marek Behun <kabel@blackhole.sk> SVN-Revision: 48267
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 77fa991b04..bcb2103047 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -161,7 +161,7 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
- openssl version | grep OpenSSL))
+ openssl version | grep '\(OpenSSL\|LibreSSL\)'))
# Install ldconfig stub