summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
commit1f77bfff9608f97996bffdb28dabec4e787631f6 (patch)
tree9e624ddb58dffe5cae5af0ea17b7bd51116e3418 /include/prereq-build.mk
parented083586aaf8468794c87d65324cfe7ee015f38c (diff)
downloadmaster-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.tar.gz
master-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.tar.bz2
master-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.zip
build: BSD compile fixes
following patch allows to build images for Qemu ARM on OpenBSD 5.2 amd64 and FreeBSD 9.1 amd64. Mostly small pieces of code changes to get things right on the specific platform. Updated the README to describe better, which tools on the host are required. Added some kind of prepare scripts to install needed tools on BSD via packages. Signed-off-by: Waldemar Brodkorb <mail@waldemar-brodkorb.de> SVN-Revision: 35900
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c7d59f1202..59ea7ef9a7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -39,6 +39,8 @@ $(eval $(call Require,case-sensitive-fs, \
))
define Require/getopt
+ gnugetopt --help 2>&1 | grep long >/dev/null || \
+ /usr/local/bin/getopt --help 2>&1 | grep long >/dev/null || \
getopt --help 2>&1 | grep long >/dev/null
endef
$(eval $(call Require,getopt, \
@@ -134,15 +136,11 @@ $(eval $(call RequireCommand,bzip2, \
Please install bzip2. \
))
-$(eval $(call RequireCommand,patch, \
- Please install patch. \
-))
-
$(eval $(call RequireCommand,perl, \
Please install perl. \
))
-$(eval $(call RequireCommand,python, \
+$(eval $(call RequireCommand,$(PYTHON), \
Please install python. \
))