summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 17:38:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 17:38:54 +0000
commit13a0f0d62157e748041dcfdbd984f0642199eee9 (patch)
tree761998a13b763053043cc4dfbd65924a6885a9cb /include/prereq-build.mk
parent60eef7aefd7f203415f5c536b41869922bebf439 (diff)
downloadmaster-31e0f0ae-13a0f0d62157e748041dcfdbd984f0642199eee9.tar.gz
master-31e0f0ae-13a0f0d62157e748041dcfdbd984f0642199eee9.tar.bz2
master-31e0f0ae-13a0f0d62157e748041dcfdbd984f0642199eee9.zip
include: fix prereq tests for perl and file (#18911)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44296
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7945f05325..926a06f8ba 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -132,7 +132,7 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
- perl --version | grep "perl 5"))
+ perl --version | grep "perl.*v5"))
$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
python2.7 -V 2>&1 | grep Python, \
@@ -146,7 +146,7 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
git clone 2>&1 | grep -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
- file --version | grep file))
+ file --version 2>&1 | grep file))
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
openssl version | grep OpenSSL))