summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:28 +0000
commit095fe8743b64a47ea2b13642934348f914d2a2bb (patch)
tree5135ab9769548063bb0a8a31a89b3f32fc447bfb /include/prereq-build.mk
parent94a96244f6db24adedcb3e6f3be07c7cafa484e9 (diff)
downloadmaster-31e0f0ae-095fe8743b64a47ea2b13642934348f914d2a2bb.tar.gz
master-31e0f0ae-095fe8743b64a47ea2b13642934348f914d2a2bb.tar.bz2
master-31e0f0ae-095fe8743b64a47ea2b13642934348f914d2a2bb.zip
prereq-build.mk: do not perform static linking tests on Darwin
SVN-Revision: 33139
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk35
1 files changed, 20 insertions, 15 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 74f1e32a6e..c7d59f1202 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/host-build.mk
PKG_NAME:=Build dependency
@@ -70,24 +71,26 @@ $(eval $(call Require,working-g++, \
Please install the GNU C++ Compiler (g++). \
))
-define Require/working-gcc-static
+ifneq ($(HOST_STATIC_LINKING),)
+ define Require/working-gcc-static
echo 'int main(int argc, char **argv) { return 0; }' | \
- gcc -x c -static -o $(TMP_DIR)/a.out -
-endef
+ gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -
+ endef
-$(eval $(call Require,working-gcc-static, \
+ $(eval $(call Require,working-gcc-static, \
Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
-))
+ ))
-define Require/working-g++-static
+ define Require/working-g++-static
echo 'int main(int argc, char **argv) { return 0; }' | \
- g++ -x c++ -static -o $(TMP_DIR)/a.out - -lstdc++ && \
+ g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out
-endef
+ endef
-$(eval $(call Require,working-g++-static, \
+ $(eval $(call Require,working-g++-static, \
Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
-))
+ ))
+endif
define Require/ncurses
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
@@ -108,14 +111,16 @@ $(eval $(call Require,zlib, \
Please install zlib. (Missing libz.so or zlib.h) \
))
-define Require/zlib-static
+ifneq ($(HOST_STATIC_LINKING),)
+ define Require/zlib-static
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
- gcc -include zlib.h -x c -static -o $(TMP_DIR)/a.out - -lz
-endef
+ gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz
+ endef
-$(eval $(call Require,zlib-static, \
+ $(eval $(call Require,zlib-static, \
Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
-))
+ ))
+endif
$(eval $(call RequireCommand,gawk, \
Please install GNU awk. \