summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-29 11:37:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-29 11:37:10 +0000
commit9e5db437f294284f8d1cb6bf3fd078dfca0bea30 (patch)
treeda83a7440f379bcd261084dbb485dfba15758dc6 /include/prereq-build.mk
parent2675ade97a115d3ba1e75fb1193365cd87310fcf (diff)
downloadmaster-31e0f0ae-9e5db437f294284f8d1cb6bf3fd078dfca0bea30.tar.gz
master-31e0f0ae-9e5db437f294284f8d1cb6bf3fd078dfca0bea30.tar.bz2
master-31e0f0ae-9e5db437f294284f8d1cb6bf3fd078dfca0bea30.zip
prereq-build: test availability of Perl Thread::Queue module
This is needed for building automake. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47069
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f5fb9e270a..6f491375c6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -76,6 +76,10 @@ $(eval $(call TestHostCommand,libssl, \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+$(eval $(call TestHostCommand,perl-thread-queue, \
+ Please install the Perl Thread::Queue module, \
+ perl -MThread::Queue -e 1))
+
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \