summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-20 09:17:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-20 09:17:56 +0000
commit35b34b20d447b06eb741523163df7aa3ff1f4ae0 (patch)
treea48df30360a0ecb5a61d8de421c81f30a96cab75 /include/prereq-build.mk
parentc68b74e5c4a53e08fb7293d021952215c059c755 (diff)
downloadmaster-31e0f0ae-35b34b20d447b06eb741523163df7aa3ff1f4ae0.tar.gz
master-31e0f0ae-35b34b20d447b06eb741523163df7aa3ff1f4ae0.tar.bz2
master-31e0f0ae-35b34b20d447b06eb741523163df7aa3ff1f4ae0.zip
prereq-build: replace the openssl command check with a check for headers
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42995
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index cb23f85647..4a87c9211a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,8 +168,13 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
-$(eval $(call RequireCommand,openssl, \
- Please install openssl. \
+define Require/openssl
+ echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
+ gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
+endef
+
+$(eval $(call Require,openssl, \
+ Please install openssl (with development headers) \
))
define Require/gnu-find