summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-20 17:37:18 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-20 17:37:18 +0000
commitfc5f02410f27de8b2b97a8edccb859773094591e (patch)
tree1f9f3f993475af1553c25b83a27fe551ce4f567f /include/package.mk
parent7b4d039e00b0e29f416c21a022ce2a6db23a4c30 (diff)
downloadmaster-31e0f0ae-fc5f02410f27de8b2b97a8edccb859773094591e.tar.gz
master-31e0f0ae-fc5f02410f27de8b2b97a8edccb859773094591e.tar.bz2
master-31e0f0ae-fc5f02410f27de8b2b97a8edccb859773094591e.zip
buildroot: move hardening options into separate file
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46070
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk47
1 files changed, 1 insertions, 46 deletions
diff --git a/include/package.mk b/include/package.mk
index 7ba7401d44..6538afe3e2 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -14,13 +14,6 @@ PKG_INSTALL_DIR ?= $(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM ?= unknown
PKG_BUILD_PARALLEL ?=
PKG_USE_MIPS16 ?= 1
-PKG_CHECK_FORMAT_SECURITY ?= 1
-PKG_CC_STACKPROTECTOR_REGULAR ?= 1
-PKG_CC_STACKPROTECTOR_STRONG ?= 1
-PKG_FORTIFY_SOURCE_1 ?= 1
-PKG_FORTIFY_SOURCE_2 ?= 1
-PKG_RELRO_PARTIAL ?= 1
-PKG_RELRO_FULL ?= 1
ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
@@ -40,46 +33,8 @@ ifdef CONFIG_USE_MIPS16
TARGET_CFLAGS += -mips16 -minterlink-mips16
endif
endif
-ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
- ifeq ($(strip $(PKG_CHECK_FORMAT_SECURITY)),1)
- TARGET_CFLAGS += -Wformat -Werror=format-security
- endif
-endif
-ifdef CONFIG_PKG_CC_STACKPROTECTOR_REGULAR
- ifeq ($(strip $(PKG_CC_STACKPROTECTOR_REGULAR)),1)
- TARGET_CFLAGS += -fstack-protector
- TARGET_LDFLAGS += -fstack-protector
- endif
-endif
-ifdef CONFIG_PKG_CC_STACKPROTECTOR_STRONG
- ifeq ($(strip $(PKG_CC_STACKPROTECTOR_STRONG)),1)
- TARGET_CFLAGS += -fstack-protector-strong
- TARGET_LDFLAGS += -fstack-protector-strong
- endif
-endif
-ifdef CONFIG_PKG_FORTIFY_SOURCE_1
- ifeq ($(strip $(PKG_FORTIFY_SOURCE_1)),1)
- TARGET_CFLAGS += -D_FORTIFY_SOURCE=1
- endif
-endif
-ifdef CONFIG_PKG_FORTIFY_SOURCE_2
- ifeq ($(strip $(PKG_FORTIFY_SOURCE_2)),1)
- TARGET_CFLAGS += -D_FORTIFY_SOURCE=2
- endif
-endif
-ifdef CONFIG_PKG_RELRO_PARTIAL
- ifeq ($(strip $(PKG_RELRO_PARTIAL)),1)
- TARGET_CFLAGS += -Wl,-z,relro
- TARGET_LDFLAGS += -Wl,-z,relro
- endif
-endif
-ifdef CONFIG_PKG_RELRO_FULL
- ifeq ($(strip $(PKG_RELRO_FULL)),1)
- TARGET_CFLAGS += -Wl,-z,now -Wl,-z,relro
- TARGET_LDFLAGS += -Wl,-z,now -Wl,-z,relro
- endif
-endif
+include $(INCLUDE_DIR)/hardening.mk
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk