summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-18 00:37:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-18 00:37:18 +0000
commite9e6e75c2a78bcd3fc3f83d19e88be15a6fb31cf (patch)
tree21b7cf56f1940104114229a64012eaf9017e85e3 /include/package.mk
parent91ce10a184ec97ec0c9a748ee0a9c88664c7305f (diff)
downloadmaster-31e0f0ae-e9e6e75c2a78bcd3fc3f83d19e88be15a6fb31cf.tar.gz
master-31e0f0ae-e9e6e75c2a78bcd3fc3f83d19e88be15a6fb31cf.tar.bz2
master-31e0f0ae-e9e6e75c2a78bcd3fc3f83d19e88be15a6fb31cf.zip
build: explicitly unexport CONFIG_SITE
On systems with CONFIG_SITE in the environment (e.g. OpenSUSE) make will export the CONFIG_SITE set in include/package.mk by default. This will cause host builds to get the target site configuration, leading to all kinds of weirdness (wrong pointer size, wrong endianess). Fix this by explicitly unexporting CONFIG_SITE. The explicit export for the target builds overrides the unexport, so the target builds will still correctly get the site config. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 44019
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 2c34a5850c..8208e36cfc 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -131,7 +131,7 @@ CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
SUBMAKE:=$(NO_TRACE_MAKE) $(if $(CUR_MAKEFILE),-f $(CUR_MAKEFILE))
PKG_CONFIG_PATH=$(STAGING_DIR)/usr/lib/pkgconfig:$(STAGING_DIR)/usr/share/pkgconfig
-unexport QUIET
+unexport QUIET CONFIG_SITE
ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)