summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-04 12:28:55 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-04 12:28:55 +0000
commite5fc77edd957fac0b0496594bd55a9662d3a7a2a (patch)
treea83d59f245c986328d0a3b53c5645daeb770f7d6 /include/package.mk
parent635ec6e7d957a6cbb2b1e1b1af7288415e578aa3 (diff)
downloadmaster-31e0f0ae-e5fc77edd957fac0b0496594bd55a9662d3a7a2a.tar.gz
master-31e0f0ae-e5fc77edd957fac0b0496594bd55a9662d3a7a2a.tar.bz2
master-31e0f0ae-e5fc77edd957fac0b0496594bd55a9662d3a7a2a.zip
Lock copying of directory trees to the staging dir with the "staging-dir" lock. This lock probably has to be taken elsewhere, too.
SVN-Revision: 23857
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 2d3a5d0966..712b793d0d 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -132,8 +132,10 @@ define Build/DefaultTargets
$(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
)
if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
- (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)); \
- $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
+ $(call locked, \
+ (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)); \
+ $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
+ ,staging-dir); \
fi
rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
touch $$@