summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-03 00:17:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-03 00:17:08 +0000
commitde4fdd0ce61f9ca76d5c6eca43a1c1957e5d411f (patch)
treed75140f38413c5bf63f3c10a5d5d6be39da181b6 /include/package.mk
parent3494bdc59a1f68a79c8ab268737e4513b4a801ce (diff)
downloadmaster-31e0f0ae-de4fdd0ce61f9ca76d5c6eca43a1c1957e5d411f.tar.gz
master-31e0f0ae-de4fdd0ce61f9ca76d5c6eca43a1c1957e5d411f.tar.bz2
master-31e0f0ae-de4fdd0ce61f9ca76d5c6eca43a1c1957e5d411f.zip
add a stamp that can forcibly disable autorebuild for a specific package - useful for testing changes to packages with extremely long recompilation times
SVN-Revision: 25838
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 324e6e8452..1cf4d64cc9 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -24,7 +24,14 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
+STAMP_NO_AUTOREBUILD=$(wildcard $(PKG_BUILD_DIR)/.no_autorebuild)
+PREV_STAMP_PREPARED:=$(if $(STAMP_NO_AUTOREBUILD),$(wildcard $(PKG_BUILD_DIR)/.prepared*))
+ifneq ($(PREV_STAMP_PREPARED),)
+ STAMP_PREPARED:=$(PREV_STAMP_PREPARED)
+ CONFIG_AUTOREBUILD:=
+else
+ STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
+endif
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
STAMP_INSTALLED:=$(STAGING_DIR)/stamp/.$(PKG_NAME)_installed