summaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
commitcf788fc7317c3e4a5bab17194c680ed5b0df39a7 (patch)
tree54033494addfdcb52ee6189f0578856d9422ff92 /include/package.mk
parent3051de8701b5c13e4df781c52950c68234b04ee4 (diff)
downloadmaster-31e0f0ae-cf788fc7317c3e4a5bab17194c680ed5b0df39a7.tar.gz
master-31e0f0ae-cf788fc7317c3e4a5bab17194c680ed5b0df39a7.tar.bz2
master-31e0f0ae-cf788fc7317c3e4a5bab17194c680ed5b0df39a7.zip
build: add a config option for choosing the prefered standard c++ library and add uclibc++.mk to make this easy to handle in packages
SVN-Revision: 32369
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index e955c207ae..abffa0c64c 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -5,6 +5,8 @@
# See /LICENSE for more information.
#
+__package_mk:=1
+
all: $(if $(DUMP),dumpinfo,compile)
PKG_BUILD_DIR ?= $(BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))